Premièrement partitionner. Je décide de laisser le partitionnement en GPT et l'emploi de gdisk en lieu et place du fdisk habituel ne pose pas trop de problème. La question serait plus délicate s'il s'agissait de conserver partiellement Windows mais comme l'emploi d'un LiveCD n'est pas possible, je ne peux pas utiliser gparted.

À défaut d'être gravée dans le marbre ma procédure d'installation fait l'objet d'une petite fiche qui me permet des copier / coller dès lors que j'ai pu me connecter en ssh. Du reste je me demande pourquoi openssh n'est pas installé / démarré par défaut dans l'iso officielle. En attendant je tape les commandes habituelles :

loadkeys fr                 # pour avoir le clavier en français
pacman -Sy openssh # installer openssh
passwd # donner un mot de passe à root pour se loguer en ssh
nano /etc/ssh/sshd_config # et décommenter la ligne PermitRootLogin yes
ifconfig # pour connaître l'adresse ip
systemctl start sshd # et roule ma poule !

Je n'ai donc plus qu'à me connecter depuis un poste muni d'une interface graphique et  suivre mes fiches ou l’excellent wiki d'Archlinux. Pour les anglophobes il existe un wiki en français mais moins complet (comme d'hab). Je ne ferai donc pas un compte rendu détaillé mais me contenterai des résolutions des quelques petites difficultés rencontrées.

Grub et EFI

J'ai l'habitude d'utiliser grub comme chargeur d'amorçage, et avait pris soin de charger le module efivars avant le arch-chroot. Mais j'ai eu droit à un magnifique

modprobe: FATAL: Module efivars not found

Donc /sys/firmware/efi/efivars restait vide dans l'environnement d'installation et grub refusait de s'installer correctement. Le bug (incompatibilité de niveau entre le noyau et efibootmgr) et son contournement sont expliqués ici mais comme j'avais utilisé avec succès l'iso du mois de septembre j'ai tout simplement fini l'installation de grub avec celle-ci. Après boot sur la clé :

modeprobe efivars
arch-chroot

puis classiquement (grub, dosfstools et efibootmgr ayant été installés préalablement) :

mkdir /boot/efi
mount /dev/sdax /boot/efi/
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
grub-mkconfig -o /boot/grub/grub.cfg
J'espère que le problème sera résolu sur la prochaine iso.

xorg

Après installation de xorg je me suis contenté d'installer xf86-video-intel sans installer ni nouveau ni le pilote propriétaire. Et comme je l'espérais cela a fonctionné sans problème. Comme ce PC est destiné à la bureautique et un peu de multimédia cela suffit amplement.

Par mesure de sécurité j'ai blacklisté le module nouveau et installé bbswitch pour éteindre la carte au boot :
-> options bbswitch load_state=0 dans /etc/modprobe.d/bbswitch.conf

Pour tout savoir sur optimus sous Archlinux voir la page de wiki consacrée à Bumblebee (la page en français pour les anglophobes)

Wifi

Maintenant que xorg fonctionne, que j'ai installé KDE et vérifié que le son fonctionne, il reste à m'occuper du réseau. Toute l'installation a été faite en utilisant l'interface ethernet, mais ma fifille utilise soit le wifi soit une clé 3G. Pour cette dernière partie il suffit d'installer modemmanager en complément de NetworkManager ainsi que usb_modeswitch. Voir la documentation ici.

Pour le wifi ça a été plus compliqué : impossible d'activer la carte, témoin éteint et touche de fonction prévue à cet usage sans effet. rfkill list me confirme cet état de fait :

rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes

Tout d'abord je ne comprend pas pourquoi je vois 2 cartes au lieu d'une mais après des heures carrées de recherche sur le web je fini par trouver ce post ou un gus suggérait de blacklister un module hp-wmi. Chez moi c'était naturellement un asus-wmi que j'ai blaclisté et effectivement j'ai pu utiliser le wifi. Et rfkill list ne me montre plus qu'une carte, comprenne qui peut.

rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Le témoin reste éteint, la touche de fonction sans effet mais le wifi fonctionne. Bah....

Sortie de veille

Ultime vérification avant de livrer l'appareil à son destinataire, et notamment mise en veille. Et nouveau problème ! Plus de réseau ethernet en sortie de veille (le wifi fonctionne). dmesg me montre des tonnes d'erreur

kernel: alx 0000:04:00.0: invalid PHY speed/duplex: 0xffff

ifconfig up et systemctl restart NetworkManager sont sans effet, et le système crash à l'arrêt de la machine.

C'est de toute évidence le pilote alx de la carte qui est en cause. La solution est donc de le décharger à la mise en veille et de le recharger en sortie de veille. Un peu bricolo, pas très élégant, mais ça fonctionne.

sudo nano /etc/systemd/system/root-suspend.service
[Unit]
Description=Local system suspend actions
Before=sleep.target
[Service]
Type=simple
ExecStart=/usr/bin/rmmod alx
[Install]
WantedBy=suspend.target
sudo nano /etc/systemd/system/root-resume.service
[Unit]
Description=Local system resume actions
After=suspend.target
[Service]
Type=simple
ExecStart=/usr/bin/modprobe alx
[Install]
WantedBy=suspend.target

et rendre tout ceci actif au démarrage :

sudo systemctl enable root-suspend
sudo systemctl enable root-resume

Ici le post ou j'ai trouvé cette solution.

Conclusion

bon, c'est pas franchement du "out of the box", mais tout fonctionne. Youpi !

Annexe : Demande de remboursement de la taxe Windows

Mail adressé à acf_coa@asus.com

Bonjour,

Je viens de faire l’acquisition d’un Ultrabook Asus X75VD-TY256H Numéro de série D3N0CX286768119
Je suis très content de cet achat, cependant, je ne souhaite pas conserver le système d’exploitation Windows 8 qui ne me convient pas.

Je n’ai pas encore démarré la machine. Pourriez-vous me donner la procédure afin d’obtenir le remboursement de la licence Windows 8.

Mes coordonnées :
Vincent Gay
xxxxxxxxxxx, 74000 Annecy - France
Téléphone : +33 (0)4 50 xx xx xx

Vous trouverez en pièce jointe :
- copie de la facture d'achat
- copie de la page 1 de la « carte de garantie ASUS »
- photo de l'étiquette Windows situé sous l'appareil

Cordialement,

J'ai eu en retour deux formulaires pré-remplis que je n'ai eu qu'à signer et à renvoyer à la même adresse.